Start a new topic

Soft reboot hangs on "Rebooting... reboot: Restarting system"


I'm working on teh TS-7553-V2 (Rev. D), with the ts7553-V2-dec152017.tar.bz2 image.

I tried soft-rebooting the system with the reboot command.

System entered shut-down flow, but hanged in:

[  OK  ] Stopped Replay Read-Ahead Data.
         Stopping Collect Read-Ahead Data...
[  OK  ] Stopped Collect Read-Ahead Data.
[  OK  ] Reached target Shutdown.
[ 1680.164379] watchdog watchdog0: watchdog did not stop!
[ 1680.848623] reboot: Restarting system

 I've seen some stuff in the internet (including imx6 fixes).

Hi Rami,

Can you give us more detail?  I have a TS-7553-V2 Rev. D right here, running the December 15 image,  and it reboots consistently on command.

  1. <snip>
  2. [ OK ] Stopped Collect Read-Ahead Data. 
  3. [ OK ] Reached target Shutdown. 
  4. [ 28.403643] watchdog watchdog0: watchdog did not stop! 
  5. [ 30.694263] reboot: Restarting system 

  6. U-Boot 2016.03-00308-g9c14675 (Jan 15 2018 - 09:42:45 -0800) 

  7. CPU: Freescale i.MX6UL rev1.1 at 396 MHz 
  8. Reset cause: POR 
  9. Board: Technologic Systems TS-7553-V2 
  10. I2C: ready 
  11. DRAM: 512 MiB 
  12. MMC: FSL_SDHC: 0, FSL_SDHC: 1 
  13. *** Warning - bad CRC, using default environment 

  14. Net: FEC0 [PRIME] 
  15. Booting from the eMMC ... 
  16. ** File not found /boot/boot.ub ** 
  17. 34511 bytes read in 167 ms (201.2 KiB/s) 
  18. 5460520 bytes read in 391 ms (13.3 MiB/s) 
  19. NO CHRG jumper is set, not waiting 
  20. Kernel image @ 0x80800000 [ 0x000000 - 0x535228 ] 
  21. ## Flattened Device Tree blob at 83000000 
  22.    Booting using the fdt blob at 0x83000000 
  23.    Using Device Tree in place at 83000000, end 8300b6ce 

  24. Starting kernel ... 

  25. Welcome to Debian GNU/Linux 8 (jessie)! 
  26. </snip>

Usually reboot command succeeds.

I tried looking for a scenario to reproduce... not much luck.

Maybe something to do with the USB-cellular modem connected and LAN cable (only peripherals I'm using).

I happened maybe ~5 times out of ~50 attempts.

I haven't dove into it so much, hoped it's a known issue (or this-or-that miss-use on my side)

Good afternoon Rami,

One of the other engineers here pointed out that it might be interesting to see some diagnostic output.  Could you run and post this for us?

tshwctl --info

uname -a

cat /root.version 

This might shed some light on the trouble you're describing.

Login or Signup to post a comment