Start a new topic

Restore TS-7553-V2 eMMC via U-Boot UMS - bluescreen


I'm following the instructions in the WiKi (eMMC - U-Boot UMS), but constantly getting a blue-screen on my host.

I'm connecting the TS to an Ubuntu 14 VirtualBox guest, running on a Windows 10 host.

I ran mkfs.ext3 /dev/sdb1 successfully (I think), but couldn't mount /dev/sdb1 because it never showed... then came the blue-screen.

After that - blue-screen after running run emmc-ums.


Hi Rami,

Unfortunately I don't have enough detail here to give you more than a vague guess as to what's going on.  A blue-screen is generally something that happens when your Microsoft Windows product has encountered a fatal error.  Perhaps your virtual machine is not configured properly for USB pass-through?

I'm not sure where you are using "run emmc-ums" in this context.  This command would be run in u-boot on the TS-7553-V2, which would have nothing at all to do with Windows or VirtualBox, so I would be incredibly surprised to find running this command on the TS-7553-V2 would cause your desktop PC to blue-screen.  Naively, this sounds like something is very, very wrong with your desktop computer.

Obviously it's an issue in my PC.

Even if the USB device-descriptor generated by the U-Boot is invalid - it shouldn't crash the host.

I posted in the forum, hoping anyone has encountered the issue.

The issue happens a few minutes after I connect the TS-7553-V2 (U-Boot UMS) to my Ubuntu 14 (running as a VirtualBox guest on Windows 10).

The TS-7553-V2 WiKi has a note:

It is recommended to use a host PC with a native linux install. It has been observed that some VMs fail to correctly pass-through the USB device created on the TS-7553-V2 in U-Boot for UMS.

I thought it might be related, or a known issue.

I'll re-check my VirtualBox settings.


Even on a native Linux machine (Ubuntu 16.04) the WiKi instructions failed on mkfs.ext3 /dev/sdb1.

I finally restored the eMMC by booting from SD and following the WiKi instructions (5.3.2 Booted from SD).

After that, the run emmc-ums worked as expected.

I still don't know what the original issue was.

Login or Signup to post a comment